Wrong/missing data on system view page

There is nothing wrong with your data. We don’t post monthly returns until you have at least a month worth of data. We don’t calculate Sharpe or Annual Return until, again, 30 days have elapsed. And finally, there is nothing wrong with your APD that I can see. If you disagree please let me know specifically why you think it is wrong.

There is nothing wrong with your data. We don’t post monthly returns until you have at least a month worth of data. We don’t calculate Sharpe or Annual Return until, again, 30 days have elapsed. And finally, there is nothing wrong with your APD that I can see. If you disagree please let me know specifically why you think it is wrong.

It is true that recently we made a change so that Sharpe would not be calculated without at least 30 days’ data. On the other hand, there has been no change to the Month Returns area – that has always required 30 days’ worth of data.



Regarding APD, it’s possible to have a negative APD in your case because some of the trades you closed yesterday have not yet had their maximum drawdowns calculated (this is an offline processing job that happens in background) and so essentially APD may be based on slightly delayed data. Your stats should catch up with your recently closed trades shortly.

"APD could NOT be negative when the system has a positive closing and a positive opening."



It could because APD doesn’t include trades with no risk calculation on them, ie the ones that have n/a instead of low, normal or high. You have several n/a trades which total more than your total profit so far, hence the negative APD number.