C2DS Syncing problems


a year ago I had problems syncing my software with C2 through C2DS sometimes receiving an “Unknown session” message from C2DS. I realized I forgot to close the session and after that was fixed everything worked fine for a about a year.

Since 09/29/2011 these problems reappeared out of nothing (my software hasn’t changed). It only happens between 5am and 7am GMT

Has anyone experienced the same problems ? Has anyone got an explanation for this ?

Best regards,


Hi, Wouter:

Thanks for the heads up. I have a suspicion about what is going on here. Let me try a few things that will hopefully fix the issue.

Hi Matthew,

in the last post you said you we’re going to try a few things and I must say it helped … unfortunately only for a while :frowning:

Syncing problems started again somewhere on july 18. Here are some dates (European format, UTC/GMT), I might have missed some

2011-07-18 17:02

2011-07-29 08:02

2011-08-02 08:02

2011-08-11 04:02

2011-08-11 15:02

2011-08-12 08:02

2011-08-12 14:02

2011-08-12 21:02

2011-08-16 08:02

2011-08-16 17:02

2011-08-17 05:02

2011-08-23 10:02

2011-08-23 21:02

2011-08-24 05:02

2011-08-24 08:02

2011-08-25 08:02

2011-08-25 14:02

It seems to be somewhat systematic.

Any ideas ?

Best regards,



To get to the bottom of this, I’d like to see a complete log of the requests you make and responses by C2. Can you log this, including timestamps, so that I can see a complete log of one of these sessions where the timeout occurs?


I’ll will make the necessary changes to make a complete log file.

I’ll keep you posted.



I’ve made a log file as requested.

Where should I send it to ?

Best regards,


help@collective2.com and say I requested it so it gets to me asap. I’ll be on the look out.


have you got any news on the syncing problems ?

I still get many errors.


It seems that what is happening is that the read-only database used for XML session management is falling behind our master database. I’m working on fixing the root cause of this, but in the meantime, I’ve tried to make XML session authentication handle this circumstance a bit more gracefully. Please keep me posted on your experience.