Cannot Enter Stop-Market Orders

I cannot enter stop-market orders using the “New Trade” web interface. I have two hypothetical open positions and I want to enter stop-loss orders for them using the web page interface but it does not work. It used to work this way last week and now something has changed and the “New Trade” web interface will not let me submit a stop-market (or limit, for symptom elaboration) order: only market orders seem to be allowed. I do not want to close the position. Just manually enter a stop-loss.

I have tried different computers, browsers and networks and the same error persists across all of them.

Nothing has changed. Try to be as specific as possible. Tell us what system ID you are talking about. Tell us specifically what trade you are trying to enter. Tell us what response you get. I will explain to you how to do what you want. Please try to provide a screen shot of what you are trying do, with a lot of explicit detail about what you are trying, and I will try to help.

Be sure that you use “BuyToClose”, “BuyToClose” order purpose… otherwise C2 will reject all your Stop or Limit orders with opposite direction. MatthewKlein,

The system ID is 95883303 (Frontier LTD) and I am not able to enter a Stop-Market or Limit order in the opposite direction of an open trade. Market orders look like they will work (submit button not greyed out) but I do not want to close the position “at the market” presently.

This problem first appeared yesterday evening and the same symptoms persist today. I have attached screen shots showing the visual clues related to my experience with this error.

I have previously (previous to yesterday) been able to enter a stop-market order for an open position without any problems.

Please help me solve this problem. Is it operator error? If so, please explain what I am doing wrong. Otherwise, please fix it if there is a technical problem with the system.

Thank you for listening.

Andrew Danik

Did you tried the simple 1322.5 price format (without comma) ?


Thanks for showing me the cause of my order entry problem. Yes, it was OPERATOR ERROR! The problem was right in front of my face and I did not see it. Now I can laugh at how simple the solution is… :slight_smile:

The comma in the data is what prevents me from entering the order. I was pasting the stop price from the clipboard. When I eliminate the comma it works correctly.

Thanks again for showing me the solution to the problem

Andrew Danik

Hey, you are Welcome!

We develop really complicated softwares and strategies and 90% of bugs, problems are very simple, but so hard to find them :smile:

So, my eyes are “trained”…

Happy trading!