Problems with Autotrade sync


Please look at my account.

I had set autotrade to 100% of the vendors account size but told it that I only wanted to trade 4 contracts.

Autotrade has been buying and selling on the vendor’s signal, but then sync has been adding one more contract much later and at a loss I might add to match the vendor’s position, which means in essence the % value has been overriding the maximum contract value.

I have used the autotrade system before and don’t remember this problem,but then I think then it was either a percent of the vendors account or maximum contracts.[LINKSYSTEM_41924274]

Now the account is de-synced and still shows it is being autotraded, but the last

buy and sell did not show up.

In fact the account was left short 2 which I closed at a profit so that I broke even.

I am not mad, even though the execution was scrambled I took control and broke even on the day.

I would just like to know all the ins and outs of how to set autotrading up to actually work and be able to turn sync on and off as needed.

I don’t understand why you are turning sync off (or leaving it off). You must leave it on for Gen3 autotrading.

… And I would be happy to look in greater detail at the server audit logs, but I can’t understand from your message exactly what you think is incorrect. If you want me to investigate it will be helpful to tell me the exact time and signal you think was not traded properly. In glancing at your logs (admittedly superficially) I see nothing wrong, but I’m happy to look into specific questions, once I know what they are.

I think I understand the question a bit more.

The issue here is that the system vendor legs into his trades. This makes things complicated if you try to set both a percentage cap and quantity cap.

He’s trading quantity 5 at a time, but you want to trade 80% with a cap of 4.

This means that AutoSync will often adjust your quantity to keep you within the conflicting quantity params you have given.


System vendor issues Buy Quant 5 Limit

AutoTrade sees you want to trade 80% and thus places your trade at Buy 4.

Now you have a position of 4.

System vendor issues another order to Buy Quant 5

AutoTrade again translates this to a Buy 4 (due to your 80%).

Now you fill and have quantity 8, versus the system on C2 which has quantity 10. This meets your 80% scaling request, but remember that you set a maximum cap of 4 contracts… So now C2 sees you are over your limit and sells 4 of your position to keep you within the constraint you chose, which is 4.

The way to “fix” this is to choose a scaling % level that does not conflict with a quantity max.

If you see the vendor often trades like this:

Buy 5

Buy 5

Sell 10

Then you need to set your quant cap so that it does not conflict with you scaling.

A scaling of 80% will give you:

Buy 4

Buy 4

Sell 8

So you really need to set your quant max at 8, not 4.

Alternately, if you don’t want to trade as many as 8 contracts, then set your scaling to 40% instead of 80%.

Now you’ll have:

Buy 2

Buy 2

Sell 4

and you will not go over quantity maximum. See what I mean?


The vendor is not legging in. NO NO NO

He is using a REVERSAL strategy.

He as in he has 5 long and closes it by selling 5,

Then immediately sells 5 again. So now he is short 5.

At the next turning point he will buy 5 to close

Then buy 5 to open.

The only time he has 10 open is the last trade of the day for the last couple of days.

Auto trade was buying 5 on the signal, one more than I had ask it to, and then sync was selling the extra contract when it got around to doing it.

And I did not turn sync off, someone there did after reading my post.

I don’t know how.

I think you should return it to select % of account size OR max contracts.

We have never supported that a user could “select % of account size OR max contracts.” I’m not sure how such an idea would even work. It would require that everyone’s brokerage account has the same amount of capital as the C2 model account, which is not typically the case.

Anyway, if you don’t want to use the AutoTrade maximum quantity setting, you don’t have to. It’s completely optional.

We do require that you specify a % scaling factor for each trade, however, so that we can know how large to make your trades compared to the system’s trades.

Okay, but, in that “last trade of the day for the last couple of days” the system is legging in, and doing so in such a way that your settings won’t work. You can’t set 80% scaling with a cap of maximum 4 contracts if the vendor is trading Buy 5 plus Buy 5.

(Well,of course you can have those settings, but they will result in one trade being entered and then almost immediately exited.)

My suggestion remains: either raise the max quantity or (probably better) lower the scaling percentage. This assumes the vendor will continue to trade Buy 5 plus Buy 5. If he will not continue to leg in at the end of the day, then your current settings of a cap of 4 with 80% scaling make perfect sense.


I did not start autotrading last night until he had closed his 10 long.

All day the long system brought 5 and then 15 or 20 seconds sold one to give me my 4 and sold 5 then bought one to give me my position.

You can’t tell me that this is the way that it is supposed to work.

It takes what, 4-5 clock cycles to compare the signal to the limits placed for the account and adjust the quantities. At Gigahertz clock speeds it should all have happened within a couple of milliseconds total.

The Proper quantity should have been sent to the exchange the first time with minimal delay unless you are running the software on a 286 or a Commodore 64.

So now C2 sees you are over your limit and sells 4 of your position to keep you within the constraint you chose, which is 4.

Matthew, isn’t is a simple fix if you have C2 perform this check before the trade instead of after? i.e. suppress the trade if you are already at the max number of contracts. This has the added benefit of preventing the slippage and wasteful commissions that this kind of churn generates.

See my post above.

I did not already have the max number of contracts.

Matt’s explanation is a straw man.

The system opened the full number of contracts specified by the vendor and THEN closed the extra contract. Churn churn churn.

Auto-trade also left a position open when the system said that everything was closed, and then de-synced did not take the next set of signals at all.

I had to close the position manually.

I want a clear set of instructions as to how to set up to trade a system at less 100% so that it does not churn or oscillate I can trade more than one, and a way to turn sync off when things go goofy.


I’ve examined your audit logs and everything behaved as per your specifications. During the time in question you were actually trading at 100% scaling, not 80%, but you did indeed have a maximum quantity of 4 contracts.

Now, here is the sequence of trades.

At the beginning, you are Short 4.

Your C2 System issues a signal which looks like this: Buy to Close 100% of open position.

But (and here’s the important thing) the system issues this Buy To Close as a limit order. In other words, there is no certainty if and when this limit order will be filled.

Next, immediately after the limit order was issued, but before it was filled, the system vendor issued yet another signal: Buy To Open quantity 5.

Remember that, at the moment this order was issued by the trading system, you were short 4. The final “Buy 5” – if executed – would have brought you to Long 1, which is not greater than your maximum quantity setting of 4 contracts. (We do in fact check to see if a trade would bring you over your max quantity setting, and we do indeed perform this check before we place the trade, just as you suggest.)

So we placed that trade (Buy to open 5) at the scaling percentage you chose (100%).

Next, nearly simultaneously, both orders were filled: Your Buy To Close 4 and your Buy to Open 5. This made you long 5.

But wait – C2 had to follow your other instructions: you had previously set your maximum contracts allowed as only 4, so C2 immediately closed 1, as per your specifications.

The point is that we follow your instructions very explicitly, but we can only act on the information available at the time trades are generated; we can’t know which orders will fill in the future.

What it really boils down to is that, ideally, you should try to make your AutoTrade settings appropriate for the system in question. If your scaling percentage is set at 100% (as yours was) and the system typically trades 5 contracts (as yours did), then setting a maximum number of contracts at 4 will result in ex post adjustments being made in your account. This is not a secret plan to “churn” your account, as you suggest, but rather is our effort to follow your mathematical parameters exactly.

Let me suggest the following. A much simpler and cleaner way to handle this would to make your scaling % and max contracts numbers jibe with each other. There’s a bit of an art to it, of course:

If your system vendor opens 5 contracts typically, and your scaling is 100%, set your max to 5.

Alternately, if you want to set max to 4, then set your scaling to 80% (which it appears you subsequently did, as of 15:15 ET.)

I hope this information helps.


maybe you should put together an autotrade guide with some of these findings that may impact new traders in the future…