Does "Reverse" work?

The "reverse" feature for does not seem to work for me, When I click it, I get a pop-up asking to confirm, but then no order is placed. It is very deceptive, since the pop-up seems to confirm the order. Is this feature not implemented yet? Or is it something wrong with my account or my way of using the feature?

I have had the same problem before with the "close" feature, but that seems to work now. Actually, that may have actually been the "Quick trade: Close all positions" in the Admin menu. I followed the steps to quickly close all my position, and it again seemed that the system responded but the order was never processed. :frowning:

i tried to use reverse feature couple weeks ago, and witnessed same thing. i figured i did something wrong - maybe not.

Can you be more specific, Tim? When did you try to reverse a position, on what symbol, and why do you think it didn’t work? I searched the audit logs and looked for your most recent attempt at reversing a position. The recent attempt seemed to work fine.

Specifically, at 6:31 AM Eastern on 2/10 (Wednesday), you submitted a reversal for your short position in URE. Since the markets were closed at that time, the reverse wasn’t processed until 9:30 that morning, and which time the short position closed and then went long. The process seems to have worked without incident.

Perhaps I am looking at the wrong system or symbol? If you can give me more specific information, I can try to help.

Yes, I can reverse by submitting two orders. That does indeed work fine.

But on the trade page at the right side of each stock there are buttons labeled "Close" and "Reverse". Clicking on "reverse" gives a pop-up with the following text:

"Reverse SPY from long to short

You are about to go from long to short in SPY. Do you want to sell at market, or wait until a trigger price is reached?

Sell at market

Reverse when price reaches

Cancel, do not reverse"

I just now tried it (selecting "sell at market" and I get the message:

Collective2 is processing your reversal request. Please wait…

After a couple seconds the message disappears, but no trades are listed on the trade blotter. Presumably this should issue a pair of orders.

Hey, Tim: Thanks for gently but persistently pointing out this problem. I think I finally figured out what was causing the failure to properly handle the reversal order, and now the problem is fixed.

Give it a try and see if you agree. Sorry about that!

It worked like a charm this morning. Thanks for getting that fixed.