Execution of my trades on c2

i do not know if any body out there has the same problem that i have. the limits not getting filled and working orders go away into space and disappears. there is a delay in filling orders gets stuck on pending.

is it only me or anybody else have the same problem.

the tech support of c2 is too busy to get back to me.


I do not see any open trouble tickets from your email address.

If you have a question, please send it to help@collective2.com. Please try to be as specific as you can be. Include information such as your system id#, the time (and time zone) you tried to place a trade, the specific trade you tried to place, what you think happened, what you think should have happened, etc.

The more clear and specific you can be, the more likely we’ll be able to get to the bottom of the issue and help you.



I had a similar problem on Tuesday. I entered the order and sent it, but the order disappeared and did not fill. So I had to re-enter the order and send it again, which worked.


I also had this same problem. But I think it may have been because I was trying to trade a futures contract and the "stocks" button was highlighted (just above the trade blotter). When I switched to highlight the "futures" button, the trades went through. But there is still a fairly long delay in getting fills. Sometimes I just cancel the order and that will then say "Too late to cancel, order has been filled".