Impossible order fill .... a C2 software bug?

I just noticed that the C2 engine has filled a YMU8 BTO limit order for CCF Emini system at 11254 at 16:26 on 8/1/08 - which looks absolutely impossible from my chart reading. Although this trade is in favour of the vender I still want to report it because it looks to me could be a possible C2 software bug?

Please report using trouble ticket system. I am unable to find this order in the myriad of orders this system has recently filled.

Done. Do you see it now? Or you can look at my open positions now, there is a YMU6 bot on 8/1. That is the one. And, Matthew, after you finish investigating this error trade, could you please let me know what was the cause? Was that a C2 software bug? I’m interested to know.

Matthew, 10 minutes ago I saw that the error trade has been deleted, but now it appears again. This time C2 engine filled it at 8/3/08 21:35 (see below). What’s going on there? Could you let us know the cause - as this looks like a serious software bug to me.

Emailed, trade filled @11254 (8/3/08 21:35) 8/1/2008 Buy to open 1 @YMU8 @ limit 11254 GTC

The quote feed returned a bad tick. And your erroneous fill has now been fixed.

Matthew, it’s not that simple. Later on I found several other error fills in YMU8 and in my EU and ES positions as well. I reported all of them by using error ticket system. But I think you better look at your C2 program. I think something is wrong there. It seems to me the problem is that C2 engine somehow will go crazy on Sunday night (as I’ve never seen such error fills during week days so far) and then just randomly pick some open limit orders and fill them. I really think that you should do some debug on your C2 engine program. You can not rely on venders to report these problem by themselves … not to mention, since these errors all tend to be in favour of the venders so from venders’ point of view they would by nature have very little (if not zero) interest or motivation to report these errors.

And by the way, Matthew, where is my ES trade (short)? From this link ( ) I see that you have already deleted those 2 error fills that I reported (at 1268 and 1273) but I can not see that trade any more (neither in my front page nor in my trading page). Where is it now? It is supposed to still have some 6 short positions left and a total gain of about over $10K at current prices.

I just tried to enter a BTC order for ESU8 and the system says that I have no short positions in ESU8. Matthew, could you please fix this problem for me?

Matthew, now I see that the ES trade (6 contract of ESU8 short) has shown up - both at the front page and at the trading page. However when I tried to enter a BTC order the system still says that I don’t have ES short position right now and therefore doesn’t allow the BTC order to enter. Could you fix this please. Thank you.