Why can't I place a stop loss on a position

I submitted at stop loss yesterday on a position with Babson ETF and it did not go through. I tried again this morning and when I submit it nothing happens.

Also - I emailed info@collective2.com on Friday Aug 20 inquiring why Babson ETF trades were not executing in my OEC account and have yet to receive a reply.

Hi, William:

I am looking at your OEC EQuities account and your trades have indeed been placed and your positions match the system’s. There was a delay getting your account set up at OEC Equities, but we resolved that with the good guys at OEC Equities, so trading has begin and seems fine.

You can always see your open positions, and can modify positions, and add personalized stop losses or profit targets by going to the “Open Positions” screen reachable via the top AUTOTRADE drop-down menu.

Regarding your question about stop losses: I’m not sure from your forum post exactly what you tried to do. Were you trying to set an automated system-wide stop loss? If so, I see no system-wide automated stop loss in place for Babson ETF Timer. To set an automated stop-loss, go to the “Modify AutoTrade” screen (again, under the AUTOTRADE at the top of this screen). Next to each system you’ll see a column marked “Stop Loss.” Click “Set?” and follow the instructions there.

If what you want to do is to set a single stop loss on a single position, use the “Open Positions” screen I describe two paragraphs above this one. You’ll see a list of your open positions and you’ll see a link to “Add stop loss” next to each one.

Let me know if you have any trouble or questions.


I wasn’t trading on Friday but am trading now. I was wondering why my account missed a trade at 12:51 PM on Friday when I received an email from C2 which authorized my OEC account for trading at 11:17 AM.

I set a stop loss on a positiion as you described by selecting AutoTrade then Open Positions then selecting Add a stop loss next to the position - in this case it was TNA. I put the price in the stop field and clicked on submit. Nothing happens.

William - Email me privately about this. Tell me exactly what you are typing when you try to set your stop loss on TNA (or even, if you can, send me a screen shot); and let me try it on my end to see what it happening. It’s possible either there is a user-interafce problem in which we do not make something clear enough, or it is possible something is indeed broken for you. Either way I’d like to get to the bottom of it. My email is matthew@collective2