Instant Trade Messenger

The ITM has memory leaks. After running ITM 48h it needs up to 1GB ram.

Please debug it and fix it!


What browser (and version) are you using, Josef?

Chromium Version 6.0.446.0 (50564)

I also tested it with the Chromium stable Version 5.*

Start Chromium.

Open Collective2

Open some ITM Windows

and wait…

Start the Task Manager in Chromium and you’ll see the memory leak.

I think you mean Chrome (the browser). Chromium is the open source project, if I read correctly

Further,I just downloaded the latest beta and it was numbered 5.0.375.86 beta. Dunno where you got this number


There is the chrome project and the chromium project.

See here for details.

Firefox 3.5.5 used up about 200k today in 12 hours then started going erratic. Seems this problem needs more work.

Yes. There is a browser javascript memory leak when using Instant Trade Messenger (ITM). It’s not devastating – about 500K per day, typically. This means that people should probably restart their browser every day or so when using ITM.

We do have plans to rewrite the ITM javascript client to fix this. So far, most of our free development resources have been allocated to autotrading improvements, but ITM remains popular among customers, and so we fully intend to support it and improve it in the near future. Thanks for pointing this out.

Ok thanks for letting me know. Last night I tried IE8 instead because firefox become very unstable. After about 6 hours IE had gobbled up 1.7GB!! and app gave out of memory error, but at least the computer was stable. So I guess I just won’t use it or will have to shut it down every few hours. Does this type of leak only eat up memory that will be free when closing the app? Will it potentially interfere with other programs or just simply allocate memory that is not available to other apps? My concern is that I plan on running the trading system on the same computer and of course you understand cross memory contamination would be dangerous.


Interestingly that 1.7GB was without the activex plugin loaded since it was from a fresh install. I tried it again with the plugin loaded and its back to normal leakage :wink: