TOS config issues

Trades Own System seems like a great addition to C2. Having some problems getting it working though.

Already auto-trading a system but the TOS config doesnt automatically pick this up and asks to setup the auto-trading again. Event after you go through the process of setting up the auto-trading again though there’s no link back to the TOS page.

Shouldnt TOS just auto-detect people that already trade their own systems?




The issue is that you are trying to use a Gain account. As of this writing, the TOS program supports only FXCM accounts. But I will look into whether we can extend the program to Gain as well. Hang in there, please, while I find out.

Okay, Caps -

The TOS program now support Gain accounts.

Try to set up your autotrading again and it should recognize the TOS program.

I’m not sure whether it’s simply because it’s a new system, but I’m having a similar problem with ESO-OEC. I set up AutoTrading with Open E Cry, then ran through the TOS setup and it seemed to have took, but I checked it again this afternoon, and it’s waiting for me to set up AutoTrading again.

Jack -

I’m looking into this. Hang in there while I try to solve problem. - MK

Thanks Matt, think its working now. Jack try deleting the system from the TOS config section and trying again. That just worked for our system

Tried that, and it looks ok, now. I’ll see if it manages to hold on to the config.

Is there a way to search for all TOS Certified systems?

are TOS trades entered into C2 or entered directly in my trading account?

TOS trades would be entered through the C2 interface, so C2 can keep track of, and publish, the trade record. The trade signals are passed on to your brokerage account through a Gen 3 AutoTrade interface.

While your brokerage account is tied to your C2 TOS system, the account is, pretty much, hands off. All I do with my account at OpenECry is check the daily account statements to confirm everything is operating as it should.