TradeBullet not connecting to C2 account

TradeBullet not connecting to C2 account.

Error message says: "Collective2 Logon error: Invalid account (Uxxxxxx)"

Anyone knows why???

Question to Francis Gingras:

I usually open IB’s TWS first and then manually log on to TB. This time it did not work. But when I started with TB and let it open TWS automatically it worked.

Interestingly, my second instance of TB (I have two IB accounts) worked the way I normally log on.

Is there any explanation for it?

It turned out that in my case there was no server type of error, neither on C2, nor TB, nor IB. All of these servers were working fine. The problem was purely related to my computer currupt files in TradeBullet folders. An easy way to fix this is to uninstall TB, delete TradeBullet folders in ProgramFiles. However, with Windows 7 this is a bit different! W7 uses "virtual" folders, so I was not able at first to make a clean re-install. I solved the problem by trial and error, here is the procedure that worked for me (using W7):

1- Stop and close TB, same goes to TWS

2- Uninstall TB

3- re-start W7 (yes, otherwise some folders deletion will not be allowed because W7 thinks TB is still running, go figure…)

4- in windows Explorer, go to "Computer" and search for "TradeBullet"

5- Delete all "TradeBullet" folders, especially those found in VirtualStore

6- re-install TradeBullet, you should have this time a clean install where you need to fill in all login information (TWS and C2)